На этом форуме отвечают на конкретные вопросы. Фраза «я не понимаю, как решать» — это не вопрос. На вопрос «как решить задачу №X» вас отошлют к материалам сайта kpolyakov.spb.ru. За бессвязный поток слов и неспособность формулировать свои мысли — бан.

Если у вас не сходится ответ на какую-то задачу, пожалуйста сразу представляйте свое «правильное» решение.
Программы "заворачивайте" в тэг [pre2]...[/pre2], при этом сохраняются все отступы и применяется моноширинный шрифт. Если у вас используется сочетание "[i]" для обозначения элемента массива или строки, ставьте пробел после открывающей скобки. Иначе система выделит все дальнейшее курсивом.

Для регистрации на форуме щелкните по ссылке «Вход-регистрация» вверху страницы. В открывшееся окошко «ник» введите свою фамилию на русском языке (например, Иванов). В окошко «пароль» введите придуманный вами пароль, состоящий из латинских букв и цифр. Поставьте галочку в окошке «зарегистрироваться, я новый участник» и нажмите кнопку «ОК».

АвторСообщение



Сообщение: 28
ссылка на сообщение  Отправлено: 07.04.21 21:19. Заголовок: задача 2643 из генератора Вариант 7 (тип 26)


Здравствуйте. Пробовала решить задачу перебором пар чисел с помощью программы, но ответ получался просто огромный. Вот код задачи:
var  k, n: integer; 
a: array of integer;
f: text;
begin
k:=0;
assign (f, '26-j1.txt');
reset (f);
readln (f, n);
writeln ('n=', n);
SetLength (a, n);
for var i := 0 to n-1 do read (f, a[ i]);
close(f);
for var i:=0 to n-2 do
for var j:=i+1 to n-1 do
if a[ i]+a[j]=100 then k := k+1;;
println(k);
end.

Потом решила организовать с помощью электронной таблицы. Скопировала данные файла, вставила в первый столбец, удалила первую строку (она нам не нужна). Потом отсортировала числа по возрастанию. В столбце D написала числа по возрастанию (+1) от 1 до 99. В столбце Е написала числа по убыванию (+1) от 99 до 1. В столбце В считаю с помощью СЧЁТЕСЛИ в начальном массиве (столбец А) количество чисел, равных соответствующим значениям построчно столбца D (=СЧЁТЕСЛИ($A$2:$A$8321; "="&D1). В столбце С считаю с помощью СЧЁТЕСЛИ в начальном массиве (столбец А) количество чисел, равных соответствующим значениям построчно столбца Е (=СЧЁТЕСЛИ($A$2:$A$8321; "="&Е1). В столбец F вывела минимум среди пар чисел столбца В и С (=МИН(B1:C1)). потом нашла сумм(F1:F49) и прибавила к ним из строки 50 половину от найденного количества чисел 50 (т.е. 35). У меня получилось 3844. А в ответе 3845. Даже если найти сумму всего столбца F (с 1 по 99 строки) и разделить пополам, то все равно получается 3844.

Пожалуйста, помогите найти в чем я ошибаюсь в программе и в экселе.

Спасибо: 0 
ПрофильЦитата Ответить
Ответов - 2 [только новые]


Администратор




Сообщение: 2676
ссылка на сообщение  Отправлено: 08.04.21 20:54. Заголовок: Агаркова пишет: if a..


Агаркова пишет:
 цитата:
if a[ i]+a[j]=100 then k := k+1;;

Вы не учитываете, что когда вы использовали две корзины, они не могут участвовать в дальнейших расчётах.

___________________________________________________
Имей мужество пользоваться собственным умом. (И. Кант)
Спасибо: 0 
ПрофильЦитата Ответить



Сообщение: 29
ссылка на сообщение  Отправлено: 10.04.21 20:39. Заголовок: Спасибо. Уже поняла ..


Спасибо. Уже поняла все свои ошибки,исправила таблицу и переделала программу. Все работает.

Спасибо: 0 
ПрофильЦитата Ответить
Ответ:
1 2 3 4 5 6 7 8 9
видео с youtube.com картинка из интернета картинка с компьютера ссылка файл с компьютера русская клавиатура транслитератор  цитата  кавычки оффтопик свернутый текст

показывать это сообщение только модераторам
не делать ссылки активными
Имя, пароль:      зарегистрироваться    
Тему читают:
- участник сейчас на форуме
- участник вне форума
Все даты в формате GMT  3 час. Хитов сегодня: 101
Права: смайлы да, картинки да, шрифты нет, голосования нет
аватары да, автозамена ссылок вкл, премодерация откл, правка нет